GitHub Advisoryadvisory · Go

GHSA-9q3g-m353-cp4p Denial of Service in Packetbeat

HIGH Published 2022-02-15 Modified 2023-02-07 Official page ↗
Aliases
CVE-2017-11480
Ecosystem
Go
Packages
github.com/elastic/beats
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-404
Reviewed
2021-05-19

Affected packages

• Go github.com/elastic/beats: < 5.6.4 → fixed in 5.6.4 • Go github.com/elastic/beats: >= 6.0.0-alpha1, < 6.0.0 → fixed in 6.0.0

Description

Packetbeat versions prior to 5.6.4 and 6.0.0 are affected by a denial of service flaw in the PostgreSQL protocol handler. If Packetbeat is listening for PostgreSQL traffic and a user is able to send arbitrary network traffic to the monitored port, the attacker could prevent Packetbeat from properly logging other PostgreSQL traffic.

Related

Alias · CVE (1)

  • CVE-2017-11480 Packetbeat versions prior to 5.6.4 are affected by a denial of service flaw in the PostgreSQL protocol handler. vulnerability

Weakness · CWE (1)

  • CWE-404 Improper Resource Shutdown or Release weakness

References