GitHub Advisoryadvisory · npm
GHSA-9q64-mpxx-87fg Open Redirect in ecstatic
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- ecstatic
- Severity
- High
- Weaknesses
- CWE-601
- Reviewed
- 2020-04-01
Affected packages
• npm ecstatic: < 2.2.2 → fixed in 2.2.2
• npm ecstatic: >= 3.0.0, < 3.3.2 → fixed in 3.3.2
• npm ecstatic: >= 4.0.0, < 4.1.2 → fixed in 4.1.2
Description
Versions of `ecstatic` prior to 4.1.2, 3.3.2 or 2.2.2 are vulnerable to Open Redirect. The package fails to validate redirects, allowing attackers to craft requests that result in an `HTTP 301` redirect to any other domains.
Recommendation
If using `ecstatic` 4.x, upgrade to 4.1.2 or later.
If using `ecstatic` 3.x, upgrade to 3.3.2 or later.
If using `ecstatic` 2.x, upgrade to 2.2.2 or later.
Related
Weakness · CWE (1)
- CWE-601 URL Redirection to Untrusted Site weakness