GitHub Advisoryadvisory · Maven

GHSA-9qgc-p27w-3hjg High severity vulnerability that affects com.typesafe.akka:akka-http-core_2.11 and com.typesafe.akka:akka-http-core_2.12

HIGH Published 2018-10-22 Modified 2021-09-08 Official page ↗
Aliases
CVE-2018-16131
Ecosystem
Maven
Packages
com.typesafe.akka:akka-http-core_2.12, com.typesafe.akka:akka-http-core_2.11
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400
Reviewed
2020-06-16

Affected packages

• Maven com.typesafe.akka:akka-http-core_2.12: >= 10.1.0, < 10.1.4 → fixed in 10.1.4 • Maven com.typesafe.akka:akka-http-core_2.11: >= 10.1.0, < 10.1.4 → fixed in 10.1.4

Description

The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote attackers to cause a denial of service (memory consumption and daemon crash) via a ZIP bomb.

Related

Alias · CVE (1)

  • CVE-2018-16131 The decodeRequest and decodeRequestWith directives in Lightbend Akka HTTP 10.1.x through 10.1.4 and 10.0.x through 10.0.13 allow remote… vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References