GitHub Advisoryadvisory · Packagist

GHSA-9qgq-93c7-9hm4 Moodle stored Cross-site Scripting (XSS)

MEDIUM Published 2024-05-31 Modified 2025-05-30 Official page ↗
Aliases
CVE-2024-33997
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-06-04

Affected packages

• Packagist moodle/moodle: >= 4.3.0, < 4.3.4 → fixed in 4.3.4 • Packagist moodle/moodle: >= 4.2.0, < 4.2.7 → fixed in 4.2.7 • Packagist moodle/moodle: < 4.1.10 → fixed in 4.1.10

Description

Additional sanitizing was required when opening the equation editor to prevent a stored Cross-site Scripting (XSS) risk when editing another user's equation.

Related

Alias · CVE (1)

  • CVE-2024-33997 Additional sanitizing was required when opening the equation editor to prevent a stored XSS risk when editing another user's equation. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References