GitHub Advisoryadvisory · RubyGems
GHSA-9qj7-jvg4-qr2x Phusion Passenger Denial of Service
MEDIUM
Official page ↗
- Aliases
- CVE-2013-2119
- Ecosystem
- RubyGems
- Packages
- passenger
- Severity
- Moderate
- Weaknesses
- CWE-377
- Reviewed
- 2020-06-16
Affected packages
• RubyGems passenger: < 3.0.21 → fixed in 3.0.21
• RubyGems passenger: >= 4.0.1, < 4.0.5 → fixed in 4.0.5
Description
Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to cause a denial of service (prevent application start) or gain privileges by pre-creating a temporary "config" file in a directory with a predictable name in `/tmp/` before it is used by the gem.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2013-2119 Phusion Passenger gem before 3.0.21 and 4.0.x before 4.0.5 for Ruby allows local users to cause a denial of service (prevent application… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-2119 advisory
- https://access.redhat.com/errata/RHSA-2013:1136 web
- https://access.redhat.com/security/cve/CVE-2013-2119 web
- https://bugzilla.redhat.com/show_bug.cgi?id=892813 web
- https://github.com/advisories/GHSA-9qj7-jvg4-qr2x advisory
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/passenger/CVE-2013-2119.yml web
- http://blog.phusion.nl/2013/05/29/phusion-passenger-3-0-21-released web
- http://blog.phusion.nl/2013/05/29/phusion-passenger-4-0-5-released web
- http://rhn.redhat.com/errata/RHSA-2013-1136.html web