GitHub Advisoryadvisory · PyPI
GHSA-9qp4-79q8-58pr Ipsilon denial of service by deleting a SAML2 Service Provider (SP)
MEDIUM
Official page ↗
- Aliases
- CVE-2015-5301
- Ecosystem
- PyPI
- Packages
- ipsilon
- Severity
- Moderate
- Reviewed
- 2024-11-22
Affected packages
• PyPI ipsilon: >= 0.1.0, < 1.0.2 → fixed in 1.0.2
• PyPI ipsilon: >= 1.1.0, < 1.2.0 → fixed in 1.2.0
Description
providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).
Related
Alias · CVE (1)
- CVE-2015-5301 providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5301 advisory
- https://bugzilla.redhat.com/show_bug.cgi?id=1271530 web
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.0.2 web
- https://fedorahosted.org/ipsilon/wiki/Releases/v1.1.1 web
- https://github.com/ipsilon-project/ipsilon package
- https://github.com/pypa/advisory-database/tree/main/vulns/ipsilon/PYSEC-2015-42.yaml web
- https://pagure.io/ipsilon/9dec97c3c83928d231ea10f4160523a13803e594 web
- http://www.openwall.com/lists/oss-security/2015/10/27/8 web