GitHub Advisoryadvisory · npm
GHSA-9qr9-h5gf-34mp Next.js is vulnerable to RCE in React flight protocol
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- next
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2025-12-03
Affected packages
• npm next: >= 14.3.0-canary.77, < 15.0.5 → fixed in 15.0.5
• npm next: >= 15.1.0-canary.0, < 15.1.9 → fixed in 15.1.9
• npm next: >= 15.2.0-canary.0, < 15.2.6 → fixed in 15.2.6
• npm next: >= 15.3.0-canary.0, < 15.3.6 → fixed in 15.3.6
• npm next: >= 15.4.0-canary.0, < 15.4.8 → fixed in 15.4.8
• npm next: >= 15.5.0-canary.0, < 15.5.7 → fixed in 15.5.7
• npm next: >= 16.0.0-canary.0, < 16.0.7 → fixed in 16.0.7
Description
A vulnerability affects certain React packages1 for versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as CVE-2025-55182.
Fixed in:
React: 19.0.1, 19.1.2, 19.2.1
Next.js: 15.0.5, 15.1.9, 15.2.6, 15.3.6, 15.4.8, 15.5.7, 16.0.7, 15.6.0-canary.58, 16.1.0-canary.12+
The vulnerability also affects experimental canary releases starting with 14.3.0-canary.77. Users on any of the 14.3 canary builds should either downgrade to a 14.x stable release or 14.3.0-canary.76.
All users of stable 15.x or 16.x Next.js versions should upgrade to a patched, stable version immediately.
1 The affected React packages are:
• react-server-dom-parcel
• react-server-dom-turbopack
• react-server-dom-webpack
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://github.com/facebook/react/security/advisories/GHSA-fv66-9v8q-g76r web
- https://github.com/vercel/next.js/security/advisories/GHSA-9qr9-h5gf-34mp web
- https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-fmh4-wr37-44fp web
- https://nvd.nist.gov/vuln/detail/CVE-2025-55182 advisory
- https://github.com/vercel/next.js package