GitHub Advisoryadvisory · npm

GHSA-9qrh-qjmc-5w2p Denial-of-Service when binding invalid parameters in sqlite3

HIGH Published 2022-04-28 Modified 2022-05-03 Official page ↗
Aliases
CVE-2022-21227
Ecosystem
npm
Packages
sqlite3
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-248
Reviewed
2022-04-28

Affected packages

• npm sqlite3: >= 5.0.0, < 5.0.3 → fixed in 5.0.3

Description

Affected versions of sqlite3 will experience a fatal error when supplying a specific object in the parameter array. This error causes the application to crash and could not be caught. Users of `sqlite3` v5.0.0, v5.0.1 and v5.0.2 are affected by this. This issue is fixed in v5.0.3. All users are recommended to upgrade to v5.0.3 or later. Ensure there is sufficient sanitization in the parent application to protect against invalid values being supplied to binding parameters as a workaround.

Related

Alias · CVE (1)

  • CVE-2022-21227 The package sqlite3 before 5.0.3 are vulnerable to Denial of Service (DoS) which will invoke the toString function of the passed parameter. vulnerability

Weakness · CWE (1)

  • CWE-248 Uncaught Exception weakness

References