GitHub Advisoryadvisory · Maven
GHSA-9qvj-rpj8-v5c8 Pekko Management may not properly apply authenticator when Basic Authentication is enabled
MEDIUM
Official page ↗
- Aliases
- CVE-2025-46548
- Ecosystem
- Maven
- Packages
- org.apache.pekko:pekko-management_2.12, com.lightbend.akka.management:akka-management_2.13, org.apache.pekko:pekko-management_2.13, org.apache.pekko:pekko-management_3, com.lightbend.akka.management:akka-management_2.12, com.lightbend.akka.management:akka-management_3
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-287
- Reviewed
- 2025-06-06
Affected packages
• Maven org.apache.pekko:pekko-management_2.12: < 1.1.1 → fixed in 1.1.1
• Maven com.lightbend.akka.management:akka-management_2.13: < 1.6.1 → fixed in 1.6.1
• Maven org.apache.pekko:pekko-management_2.13: < 1.1.1 → fixed in 1.1.1
• Maven org.apache.pekko:pekko-management_3: < 1.1.1 → fixed in 1.1.1
• Maven com.lightbend.akka.management:akka-management_2.12: < 1.6.1 → fixed in 1.6.1
• Maven com.lightbend.akka.management:akka-management_3: < 1.6.1 → fixed in 1.6.1
Description
If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied.
Users that rely on authentication instead of making sure the Management API ports are only available to trusted users are recommended to upgrade to version 1.1.1, which fixes this issue. Akka was affected by the same issue and has released the fix in version 1.6.1.
Related
Alias · CVE (1)
- CVE-2025-46548 If you enable Basic Authentication in Pekko Management using the Java DSL, the authenticator may not be properly applied. vulnerability
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness