GitHub Advisoryadvisory · RubyGems

GHSA-9qvm-2vhf-q649 RubyGems Regular Expression Denial of Service

MEDIUM Published 2022-05-17 Modified 2023-03-08 Official page ↗
Aliases
CVE-2013-4363
Ecosystem
RubyGems
Packages
rubygems-update
Severity
Moderate
Reviewed
2023-03-08

Affected packages

• RubyGems rubygems-update: < 1.8.23.2 → fixed in 1.8.23.2 • RubyGems rubygems-update: >= 1.8.24, < 1.8.27 → fixed in 1.8.27 • RubyGems rubygems-update: >= 2.0.0, < 2.0.10 → fixed in 2.0.10 • RubyGems rubygems-update: >= 2.1.0, < 2.1.5 → fixed in 2.1.5

Description

Algorithmic complexity vulnerability in `Gem::Version::ANCHORED_VERSION_PATTERN` in `lib/rubygems/version.rb` in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.

Related

Alias · CVE (1)

  • CVE-2013-4363 Algorithmic complexity vulnerability in Gem::Version::ANCHORED_VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2,… vulnerability

References