GitHub Advisoryadvisory · RubyGems, NuGet, npm, Maven, Packagist

GHSA-9v3m-8fp8-mj99 Bootstrap Vulnerable to Cross-Site Scripting

MEDIUM Published 2019-02-22 Modified 2026-06-02 Official page ↗
Aliases
CVE-2019-8331
Ecosystem
RubyGems, NuGet, npm, Maven, Packagist
Packages
bootstrap, bootstrap-sass, Bootstrap.Less, bootstrap.sass, twitter-bootstrap-rails, org.webjars:bootstrap, twbs/bootstrap
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems bootstrap: < 4.3.1 → fixed in 4.3.1 • RubyGems bootstrap-sass: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • NuGet Bootstrap.Less: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • NuGet bootstrap: >= 4.0.0, < 4.3.1 → fixed in 4.3.1 • NuGet bootstrap: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • NuGet bootstrap.sass: < 4.3.1 → fixed in 4.3.1 • npm bootstrap: >= 4.0.0, < 4.3.1 → fixed in 4.3.1 • npm bootstrap: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • npm bootstrap-sass: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • RubyGems twitter-bootstrap-rails: < 5.3.0 → fixed in 5.3.0 • Maven org.webjars:bootstrap: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • Maven org.webjars:bootstrap: >= 4.0.0, < 4.3.1 → fixed in 4.3.1 • Packagist twbs/bootstrap: >= 3.0.0, < 3.4.1 → fixed in 3.4.1 • Packagist twbs/bootstrap: >= 4.0.0, < 4.3.1 → fixed in 4.3.1

Description

Versions of `bootstrap` prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The `data-template` attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. Recommendation For `bootstrap` 4.x upgrade to 4.3.1 or later. For `bootstrap` 3.x upgrade to 3.4.1 or later.

Related

Alias · CVE (1)

  • CVE-2019-8331 In Bootstrap before 3.4.1 and 4.3.x before 4.3.1, XSS is possible in the tooltip or popover data-template attribute. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References