GitHub Advisoryadvisory · Packagist
GHSA-9v3w-m552-m6ff Pi Cross-site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2017-7251
- Ecosystem
- Packagist
- Packages
- pi/pi
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-07
Affected packages
• Packagist pi/pi: < 2.6.0-alpha1 → fixed in 2.6.0-alpha1
Description
A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. The vulnerability exists due to insufficient filtration of user-supplied data (preview) passed to the `pi-develop/www/script/editor/markitup/preview/markdown.php` URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Related
Alias · CVE (1)
- CVE-2017-7251 A Cross-Site Scripting (XSS) was discovered in pi-engine/pi 2.5.0. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-7251 advisory
- https://github.com/pi-engine/pi/issues/1523 web
- https://github.com/pi-engine/pi/commit/557cd05b21b4d7fe422f90adcfa0c6e3bea06153 web
- https://github.com/pi-engine/pi package
- https://web.archive.org/web/20210124010656/https://www.securityfocus.com/bid/97061 web