GitHub Advisoryadvisory · npm
GHSA-9v62-24cr-58cx Denial of Service in node-sass
MEDIUM
Official page ↗
- Ecosystem
- npm
- Packages
- node-sass
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
- Reviewed
- 2020-08-31
Affected packages
• npm node-sass: >= 3.3.0, < 4.13.1 → fixed in 4.13.1
Description
Affected versions of `node-sass` are vulnerable to Denial of Service (DoS). Crafted objects passed to the `renderSync` function may trigger C++ assertions in `CustomImporterBridge::get_importer_entry` and `CustomImporterBridge::post_process_return_value` that crash the Node process. This may allow attackers to crash the system's running Node process and lead to Denial of Service.
Recommendation
Upgrade to version 4.13.1 or later
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness