GitHub Advisoryadvisory · Packagist

GHSA-9v64-447r-wch6 Moodle Temporary Passwords are Brute Force-able

HIGH Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-7845
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
Weaknesses
CWE-1391
Reviewed
2023-08-15

Affected packages

• Packagist moodle/moodle: >= 2.7.0, < 2.7.3 → fixed in 2.7.3 • Packagist moodle/moodle: >= 2.6.0, < 2.6.6 → fixed in 2.6.6 • Packagist moodle/moodle: >= 2.5.0, < 2.5.9 → fixed in 2.5.9

Description

The generate_password function in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide a sufficient number of possible temporary passwords, which allows remote attackers to obtain access via a brute-force attack.

Related

Alias · CVE (1)

  • CVE-2014-7845 The generate_password function in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 does not provide a… vulnerability

Weakness · CWE (1)

  • CWE-1391 Use of Weak Credentials weakness

References