GitHub Advisoryadvisory · PyPI

GHSA-9v8h-qqgm-4m35 Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

CRITICAL Published 2026-10-22 Modified 2026-11-03 Official page ↗
Aliases
CVE-2026-111497
Ecosystem
PyPI
Packages
brotli, brotlicffi
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-252
Reviewed
2026-10-23

Affected packages

• PyPI brotli: >= 1.0.3, < 1.2.1 → fixed in 1.2.1 • PyPI brotlicffi: >= 1.0.3, < 1.2.1.0 → fixed in 1.2.1.0

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

Related

Alias · CVE (1)

  • CVE-2026-111497 A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms… vulnerability

Weakness · CWE (1)

  • CWE-252 Unchecked Return Value weakness

References