GitHub Advisoryadvisory · RubyGems
GHSA-9v8j-x534-2fx3 Ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
CRITICAL
Official page ↗
- Aliases
- CVE-2025-66567
- Ecosystem
- RubyGems
- Packages
- ruby-saml
- Severity
- Critical
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-347
- Reviewed
- 2025-12-08
Affected packages
• RubyGems ruby-saml: < 1.18.0 → fixed in 1.18.0
Description
Summary
Ruby-saml up to and including 1.12.4, there is an authentication bypass vulnerability because of an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, the parsers can generate entirely different document structures from the same XML input. That allows an attacker to be able to execute a Signature Wrapping attack. The vulnerability does not affect the version 1.18.0.
Impact
That allows an attacker to be able to execute a Signature Wrapping attack and bypass the authentication
Related
Alias · CVE (1)
- CVE-2025-66567 The ruby-saml library is for implementing the client side of a SAML authorization. vulnerability
Weakness · CWE (1)
- CWE-347 Improper Verification of Cryptographic Signature weakness
References
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-9v8j-x534-2fx3 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-66567 advisory
- https://github.com/SAML-Toolkits/ruby-saml/commit/e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97 web
- https://github.com/SAML-Toolkits/ruby-saml package
- https://github.com/advisories/GHSA-754f-8gm6-c4r2 advisory
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/CVE-2025-66567.yml web