GitHub Advisoryadvisory · PyPI

GHSA-9v8w-xmr4-wgxp TensorFlow vulnerable to `CHECK` fail in `TensorListFromTensor`

MEDIUM Published 2022-09-16 Modified 2022-09-19 Official page ↗
Aliases
CVE-2022-35992
Ecosystem
PyPI
Packages
tensorflow, tensorflow-cpu, tensorflow-gpu
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-617
Reviewed
2022-09-16

Affected packages

• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1 • PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1 • PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2 • PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1 • PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1

Description

Impact When `TensorListFromTensor` receives an `element_shape` of a rank greater than one, it gives a `CHECK` fail that can trigger a denial of service attack. ```python import tensorflow as tf arg_0=tf.random.uniform(shape=(6, 6, 2), dtype=tf.bfloat16, maxval=None) arg_1=tf.random.uniform(shape=(6, 9, 1, 3), dtype=tf.int64, maxval=65536) arg_2='' tf.raw_ops.TensorListFromTensor(tensor=arg_0, element_shape=arg_1, name=arg_2) ``` Patches We have patched the issue in GitHub commit 3db59a042a38f4338aa207922fa2f476e000a6ee. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This vulnerability has been reported by 刘力源, Information System & Security and Countermeasures Experiments Center, Beijing Institute of Technology.

Related

Alias · CVE (1)

  • CVE-2022-35992 TensorFlow is an open source platform for machine learning. vulnerability

Weakness · CWE (1)

  • CWE-617 Reachable Assertion weakness

References