GitHub Advisoryadvisory · Packagist

GHSA-9vc3-vm42-fjhm Moodle's mod_data edit/delete pages pass CSRF token in GET parameter

LOW Published 2025-04-25 Modified 2025-04-25 Official page ↗
Aliases
CVE-2025-3637
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-598
Reviewed
2025-04-25

Affected packages

• Packagist moodle/moodle: < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4

Description

A security vulnerability was found in Moodle where confidential information that prevents cross-site request forgery (CSRF) attacks was shared publicly through the site's URL. This vulnerability occurred specifically on two types of pages within the mod_data module: edit and delete pages.

Related

Alias · CVE (1)

  • CVE-2025-3637 A security vulnerability was found in Moodle where confidential information that prevents cross-site request forgery (CSRF) attacks was… vulnerability

Weakness · CWE (1)

  • CWE-598 Use of HTTP Request With Sensitive Query String weakness

References