GitHub Advisoryadvisory · Packagist
GHSA-9vh6-qfv6-vcqp snipe-IT vulnerable to host header injection
HIGH
Official page ↗
- Aliases
- CVE-2022-23064
- Ecosystem
- Packagist
- Packages
- snipe/snipe-it
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2022-05-03
Affected packages
• Packagist snipe/snipe-it: >= 3.0-alpha, < 5.3.8 → fixed in 5.3.8
Description
Snipe-IT is a free, open-source IT asset/license management systemIn Snipe-IT, versions v3.0-alpha to v5.3.7 are vulnerable to Host Header Injection. By sending a specially crafted host header in the reset password request, it is possible to send password reset links to users which once clicked lead to an attacker controlled server and thus leading to password reset token leak. This can lead to account take over.
Related
Alias · CVE (1)
- CVE-2022-23064 In Snipe-IT, versions v3.0-alpha to v5.3.7 are vulnerable to Host Header Injection. vulnerability
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness