GitHub Advisoryadvisory · PyPI
GHSA-9vjf-jjcq-3gh7 Mercurial arbitrary code execution vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2016-3630
- Ecosystem
- PyPI
- Packages
- mercurial
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Reviewed
- 2024-05-01
Affected packages
• PyPI mercurial: < 3.7.3 → fixed in 3.7.3
Description
The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.
Related
Alias · CVE (1)
- CVE-2016-3630 The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-3630 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2016-29.yaml web
- https://security.gentoo.org/glsa/201612-19 web
- https://selenic.com/repo/hg-stable/rev/b6ed2505d6cf web
- https://selenic.com/repo/hg-stable/rev/b9714d958e89 web
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_3.7.3_.282016-3-29.29 web
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181505.html web
- http://lists.fedoraproject.org/pipermail/package-announce/2016-April/181542.html web
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00016.html web
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00017.html web
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00018.html web
- http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00043.html web
- http://www.debian.org/security/2016/dsa-3542 web
- http://www.oracle.com/technetwork/topics/security/bulletinapr2016-2952098.html web