GitHub Advisoryadvisory · npm

GHSA-9vph-2hvm-x66g Cube Core is vulnerable to Denial of Service (DoS) via crafted request

MEDIUM Published 2026-02-10 Modified 2026-02-10 Official page ↗
Aliases
CVE-2026-25957
Ecosystem
npm
Packages
@cubejs-backend/server-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-755
Reviewed
2026-02-10

Affected packages

• npm @cubejs-backend/server-core: >= 1.1.17, < 1.4.2 → fixed in 1.4.2 • npm @cubejs-backend/server-core: >= 1.5.0, < 1.5.13 → fixed in 1.5.13

Description

Impact It is possible to make the entire Cube API unavailable by submitting a specially crafted request to a Cube API endpoint. Affected Versions: `>= 1.1.17` Mitigation: Upgrade to a patched version: • 1.5.13 and later (regular release) • 1.4.2 (active LTS release) References The issue was reported by our Core engineer, Dmitrii Patsura (@ovr), in our internal Slack and was promptly patched in a recent update.

Related

Alias · CVE (1)

  • CVE-2026-25957 Cube is a semantic layer for building data applications. vulnerability

Weakness · CWE (1)

  • CWE-755 Improper Handling of Exceptional Conditions weakness

References