GitHub Advisoryadvisory · npm

GHSA-9vrw-m88g-w75q Denial of Service in @hapi/accept

HIGH Published 2020-09-03 Modified 2020-08-31 Official page ↗
Ecosystem
npm
Packages
@hapi/accept
Severity
High
Reviewed
2020-08-31

Affected packages

• npm @hapi/accept: >= 3.2.0, < 3.2.4 → fixed in 3.2.4 • npm @hapi/accept: >= 4.0.0, < 5.0.1 → fixed in 5.0.1

Description

Versions of `@hapi/accept` prior to 3.2.4 or 5.0.1 are vulnerable to Denial of Service. The Accept-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. Recommendation Upgrade to version 3.2.4 or 5.0.1.

References