GitHub Advisoryadvisory · Maven
GHSA-9w4g-fp9h-3q2v Apache Flume vulnerable to remote code execution via deserialization of unsafe providerURL
CRITICAL
Official page ↗
- Aliases
- CVE-2022-42468
- Ecosystem
- Maven
- Packages
- org.apache.flume.flume-ng-sources:flume-jms-source
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20, CWE-502
- Reviewed
- 2022-10-27
Affected packages
• Maven org.apache.flume.flume-ng-sources:flume-jms-source: < 1.11.0 → fixed in 1.11.0
Description
Flume’s JMSSource class can be configured with a providerUrl parameter. A JNDI lookup is performed on this name without performing validation. This could result in untrusted data being deserialized, leading to remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed in version 1.11.0.
Related
Alias · CVE (1)
- CVE-2022-42468 Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-42468 advisory
- https://github.com/apache/flume/commit/eee179a09df405c1ab55ae25a53b76ca1050bb97 web
- https://github.com/apache/flume package
- https://issues.apache.org/jira/browse/FLUME-3437 web
- https://lists.apache.org/thread/1ckhmp539zr2nd2rs45pocpywk2d9zvz web
- https://lists.apache.org/thread/939wkx8o90bp6m2ht3t1sdyo1ncypl78 web