GitHub Advisoryadvisory · PyPI
GHSA-9w7f-m4j4-j3xw Gerapy may cause remote code execution
CRITICAL
Official page ↗
- Aliases
- CVE-2021-43857
- Ecosystem
- PyPI
- Packages
- gerapy
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
- Reviewed
- 2022-01-05
Affected packages
• PyPI gerapy: < 0.9.8 → fixed in 0.9.8
Description
Impact
project_configure function exist remote code execute in Gerapy < 0.9.8
Patches
Patched in version 0.9.8, please install with:
```
pip3 install -U gerapy
```
Related
Alias · CVE (1)
- CVE-2021-43857 Gerapy is a distributed crawler management framework. vulnerability
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://github.com/Gerapy/Gerapy/security/advisories/GHSA-9w7f-m4j4-j3xw web
- https://nvd.nist.gov/vuln/detail/CVE-2021-43857 advisory
- https://github.com/Gerapy/Gerapy/issues/219 web
- https://github.com/Gerapy/Gerapy/commit/49bcb19be5e0320e7e1535f34fe00f16a3cf3b28 web
- https://github.com/Gerapy/Gerapy package
- https://github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2021-867.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/gerapy/PYSEC-2022-228.yaml web
- http://packetstormsecurity.com/files/165459/Gerapy-0.9.7-Remote-Code-Execution.html web