GitHub Advisoryadvisory · Go
GHSA-9w7j-q3xw-p9vh Hyperledger Fabric subject to Denial of Service via non-validated request
HIGH
Official page ↗
- Aliases
- CVE-2022-35253
- Ecosystem
- Go
- Packages
- github.com/hyperledger/fabric
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20, CWE-400
- Reviewed
- 2022-09-28
Affected packages
• Go github.com/hyperledger/fabric: < 2.4.6 → fixed in 2.4.6
Description
A vulnerability exists in Hyperledger Fabric < 2.4 could allow an attacker to construct a non-validated request that could cause a denial of service attack. The peer gateway service tries to extract channel and chaincode information from the signed proposal, but it doesn't check the proposal fields for validity. Therefore a malformed proposal might end up crashing the peer service. This issue has been patched in 2.4.6. There are no known workarounds.