GitHub Advisoryadvisory · Go

GHSA-9w8x-5hv5-r6gw Cross Site Scripting in usememos/memos

MEDIUM Published 2023-02-15 Modified 2025-03-19 Official page ↗
Aliases
CVE-2022-25978
Ecosystem
Go
Packages
github.com/usememos/memos
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-02-15

Affected packages

• Go github.com/usememos/memos: < 0.10.4-0.20230211093429-b11d2130a084 → fixed in 0.10.4-0.20230211093429-b11d2130a084

Description

All versions of the package github.com/usememos/memos/server prior to 0.11.0 are vulnerable to Cross-site Scripting (XSS) due to insufficient checks on external resources, which allows malicious actors to introduce links starting with a javascript: scheme.

Related

Alias · CVE (1)

  • CVE-2022-25978 All versions of the package github.com/usememos/memos/server are vulnerable to Cross-site Scripting (XSS) due to insufficient checks on… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References