GitHub Advisoryadvisory · Packagist
GHSA-9wc9-498w-h8xv Magento deserialization vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2020-3716
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2024-01-10
Affected packages
• Packagist magento/community-edition: >= 2.2.0, < 2.2.11 → fixed in 2.2.11
• Packagist magento/community-edition: >= 2.3.0, < 2.3.4 → fixed in 2.3.4
Description
Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a deserialization of untrusted data vulnerability. Successful exploitation could lead to arbitrary code execution.
Related
Alias · CVE (1)
- CVE-2020-3716 Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a deserialization of untrusted… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness