GitHub Advisoryadvisory · Packagist

GHSA-9wg9-93h9-j8ch Auth0 Symfony SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

CRITICAL Published 2025-05-17 Modified 2025-05-17 Official page ↗
Ecosystem
Packagist
Packages
auth0/symfony
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-287
Reviewed
2025-05-17

Affected packages

• Packagist auth0/symfony: < 5.4.0 → fixed in 5.4.0

Description

Overview Session cookies of applications using the Auth0 symfony SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using the Auth0 symfony SDK with version <=5.3.1 2. Auth0/Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. Fix Upgrade Auth0/symfony to v5.4.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References