GitHub Advisoryadvisory · Packagist

GHSA-9wjf-94h3-r4rh Magento Improper Access Control vulnerability

MEDIUM Published 2022-08-17 Modified 2024-01-11 Official page ↗
Aliases
CVE-2022-34259
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Weaknesses
CWE-284
Reviewed
2024-01-11

Affected packages

• Packagist magento/community-edition: >= 2.3.0, < 2.3.7-p4 → fixed in 2.3.7-p4 • Packagist magento/community-edition: >= 2.4.4, < 2.4.5 → fixed in 2.4.5 • Packagist magento/community-edition: >= 2.4.0, < 2.4.3-p3 → fixed in 2.4.3-p3

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to impact the availability of a user's minor feature. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2022-34259 Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References