GitHub Advisoryadvisory · RubyGems

GHSA-9wrq-xvmp-xjc8 Rails Denial of Service vulnerability

HIGH Published 2017-10-24 Modified 2025-04-03 Official page ↗
Aliases
CVE-2006-4112
Ecosystem
RubyGems
Packages
rails
Severity
High
Reviewed
2020-06-16

Affected packages

• RubyGems rails: >= 1.1.0, < 1.1.6 → fixed in 1.1.6

Description

Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute arbitrary Ruby code via a URL that is not properly handled in the routing code, which leads to a denial of service (application hang) or "data loss," a different vulnerability than CVE-2006-4111.

Related

Alias · CVE (1)

  • CVE-2006-4112 Unspecified vulnerability in the "dependency resolution mechanism" in Ruby on Rails 1.1.0 through 1.1.5 allows remote attackers to execute… vulnerability

References