GitHub Advisoryadvisory · Packagist

GHSA-9wrv-g75h-8ccc Improper Access Control in Shopware

HIGH Published 2022-04-22 Modified 2022-05-04 Official page ↗
Aliases
CVE-2022-24872
Ecosystem
Packagist
Packages
shopware/platform, shopware/core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-732
Reviewed
2022-04-22

Affected packages

• Packagist shopware/platform: < 6.4.10.1 → fixed in 6.4.10.1 • Packagist shopware/core: < 6.4.10.1 → fixed in 6.4.10.1

Description

Shopware 6 is an open commerce platform based on Symfony Framework and Vue and supported by a worldwide community and more than 1.500 community extensions. Permissions set to sales channel context by admin-api are still useable within normal user session. We recommend updating to the current version 6.4.10.1. You can get the update to 6.4.10.1 regularly via the Auto-Updater or directly via the download overview. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Related

Alias · CVE (1)

  • CVE-2022-24872 Shopware is an open commerce platform based on Symfony Framework and Vue. vulnerability

Weakness · CWE (1)

  • CWE-732 Incorrect Permission Assignment for Critical Resource weakness

References