GitHub Advisoryadvisory · Packagist
GHSA-9x63-m3cc-qf3g Moodle Unauthorized searching of arbitrary blogs by typing full url
MEDIUM
Official page ↗
- Aliases
- CVE-2017-7490
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-668
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.2, < 3.2.3 → fixed in 3.2.3
• Packagist moodle/moodle: >= 3.1, < 3.1.6 → fixed in 3.1.6
• Packagist moodle/moodle: >= 3.0, < 3.0.10 → fixed in 3.0.10
• Packagist moodle/moodle: >= 2.7, < 2.7.20 → fixed in 2.7.20
Description
In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing.
Related
Alias · CVE (1)
- CVE-2017-7490 In Moodle 2.x and 3.x, searching of arbitrary blogs is possible because a capability check is missing. vulnerability
Weakness · CWE (1)
- CWE-668 Exposure of Resource to Wrong Sphere weakness