GitHub Advisoryadvisory · Go
GHSA-9x8x-w6g5-hx4w Mattermost Server is vulnerable to XSS attacks against an OAuth 2.0 allow/deny page
MEDIUM
Official page ↗
- Aliases
- CVE-2017-18877
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-12-05
Affected packages
• Go github.com/mattermost/mattermost-server: < 4.1.2 → fixed in 4.1.2
• Go github.com/mattermost/mattermost-server: >= 4.2.0, < 4.2.1 → fixed in 4.2.1
• Go github.com/mattermost/mattermost-server: >= 4.3.0-rc1, < 4.3.0 → fixed in 4.3.0
Description
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. XSS attacks could occur against an OAuth 2.0 allow/deny page.
Related
Alias · CVE (1)
- CVE-2017-18877 An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness