GitHub Advisoryadvisory · Packagist
GHSA-9xhq-pm7v-693p phpMyAdmin Cryptographic Vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2016-9847
- Ecosystem
- Packagist
- Packages
- phpmyadmin/phpmyadmin
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Reviewed
- 2023-07-31
Affected packages
• Packagist phpmyadmin/phpmyadmin: >= 4.6, < 4.6.5 → fixed in 4.6.5
• Packagist phpmyadmin/phpmyadmin: >= 4.4, < 4.4.15.9 → fixed in 4.4.15.9
• Packagist phpmyadmin/phpmyadmin: >= 4.0, < 4.0.10.18 → fixed in 4.0.10.18
Description
An issue was discovered in phpMyAdmin. When the user does not specify a blowfish_secret key for encrypting cookies, phpMyAdmin generates one at runtime. A vulnerability was reported where the way this value is created uses a weak algorithm. This could allow an attacker to determine the user's blowfish_secret and potentially decrypt their cookies. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.
Related
Alias · CVE (1)
- CVE-2016-9847 An issue was discovered in phpMyAdmin. vulnerability