GitHub Advisoryadvisory · npm
GHSA-9xp9-j92r-p88v Parse Server crash via deeply nested query condition operators
HIGH
Official page ↗
- Aliases
- CVE-2026-32944
- Ecosystem
- npm
- Packages
- parse-server
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Weaknesses
- CWE-674
- Reviewed
- 2026-03-17
Affected packages
• npm parse-server: >= 9.0.0, < 9.6.0-alpha.21 → fixed in 9.6.0-alpha.21
• npm parse-server: < 8.6.45 → fixed in 8.6.45
Description
Impact
An unauthenticated attacker can crash the Parse Server process by sending a single request with deeply nested query condition operators. This terminates the server and denies service to all connected clients.
Patches
A depth limit for query condition operator nesting has been added via the `requestComplexity.queryDepth` server option. The option is disabled by default to avoid a breaking change. To mitigate, upgrade and set the option to a value appropriate for your app.
Workarounds
None.
Related
Alias · CVE (1)
- CVE-2026-32944 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-9xp9-j92r-p88v web
- https://nvd.nist.gov/vuln/detail/CVE-2026-32944 advisory
- https://github.com/parse-community/parse-server/pull/10202 web
- https://github.com/parse-community/parse-server/pull/10203 web
- https://github.com/parse-community/parse-server package