GitHub Advisoryadvisory · PyPI
GHSA-9xv4-r2hf-26gh Mercurial Improper Input Validation vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2018-13346
- Ecosystem
- PyPI
- Packages
- mercurial
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-05-01
Affected packages
• PyPI mercurial: < 4.6.1 → fixed in 4.6.1
Description
The `mpatch_apply` function in `mpatch.c` in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of the original data, aka OVE-20180430-0004.
Related
Alias · CVE (1)
- CVE-2018-13346 The mpatch_apply function in mpatch.c in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-13346 advisory
- https://access.redhat.com/errata/RHSA-2019:2276 web
- https://github.com/pypa/advisory-database/tree/main/vulns/mercurial/PYSEC-2018-88.yaml web
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html web
- https://www.mercurial-scm.org/repo/hg/rev/faa924469635 web
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.6.1_.282018-06-06.29 web