GitHub Advisoryadvisory · PyPI
GHSA-c2fx-8r76-gh36 python-gnupg allows context-dependent attackers to execute arbitrary commands via shell metacharacters
HIGH
Official page ↗
- Aliases
- CVE-2013-7323
- Ecosystem
- PyPI
- Packages
- python-gnupg
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2020-06-16
Affected packages
• PyPI python-gnupg: < 0.3.7 → fixed in 0.3.7
Description
python-gnupg before 0.3.5 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.
Related
Alias · CVE (1)
- CVE-2013-7323 python-gnupg before 0.3.5 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in unspecified vectors. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2013-7323 advisory
- https://code.google.com/p/python-gnupg web
- https://github.com/pypa/advisory-database/tree/main/vulns/python-gnupg/PYSEC-2014-89.yaml web
- https://github.com/vsajip/python-gnupg package
- http://seclists.org/oss-sec/2014/q1/243 web
- http://seclists.org/oss-sec/2014/q1/244 web
- http://seclists.org/oss-sec/2014/q1/294 web
- http://www.debian.org/security/2014/dsa-2946 web