GitHub Advisoryadvisory · Go

GHSA-c2h3-6mxw-7mvq Insufficiently restricted permissions on plugin directories

MEDIUM Published 2021-10-04 Modified 2021-10-15 Official page ↗
Aliases
CVE-2021-41103
Ecosystem
Go
Packages
github.com/containerd/containerd
Severity
Moderate
CVSS vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Weaknesses
CWE-22
Reviewed
2021-10-04

Affected packages

• Go github.com/containerd/containerd: < 1.4.11 → fixed in 1.4.11 • Go github.com/containerd/containerd: >= 1.5.0, < 1.5.7 → fixed in 1.5.7

Description

Impact A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. Patches This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Workarounds Limit access to the host to trusted users. Update directory permission on container bundles directories. For more information If you have any questions or comments about this advisory: • Open an issue in github.com/containerd/containerd • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2021-41103 containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References