GitHub Advisoryadvisory · Packagist

GHSA-c2r4-f8qv-2v7v Moodle allows attackers to read SCORM contents

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2015-5341
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: < 2.7.11 → fixed in 2.7.11 • Packagist moodle/moodle: >= 2.8.0, < 2.8.9 → fixed in 2.8.9 • Packagist moodle/moodle: >= 2.9.0, < 2.9.3 → fixed in 2.9.3

Description

mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which allows remote authenticated users to bypass intended access restrictions and read SCORM contents via unspecified vectors.

Related

Alias · CVE (1)

  • CVE-2015-5341 mod_scorm in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 mishandles availability dates, which… vulnerability

References