GitHub Advisoryadvisory · Maven

GHSA-c2rv-hwqm-wjpg Apache Calcite is Vulnerable to Use of Externally-Controlled Input to Select Classes

MEDIUM Published 2026-06-02 Modified 2026-07-09 Official page ↗
Aliases
CVE-2026-46718
Ecosystem
Maven
Packages
org.apache.calcite:calcite-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-470
Reviewed
2026-07-09

Affected packages

• Maven org.apache.calcite:calcite-core: >= 1.5.0, < 1.42.0 → fixed in 1.42.0

Description

Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. This issue affects Apache Calcite: from 1.5.0 before 1.42. Users are recommended to upgrade to version 1.42, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2026-46718 Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Calcite. vulnerability

Weakness · CWE (1)

  • CWE-470 Use of Externally-Controlled Input to Select Classes or Code weakness

References