GitHub Advisoryadvisory · Packagist
GHSA-c38m-9668-6j2w Magento Improper input validation vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-28585
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-20
- Reviewed
- 2024-01-11
Affected packages
• Packagist magento/community-edition: >= 2.4.0, < 2.4.2-p1 → fixed in 2.4.2-p1
• Packagist magento/community-edition: < 2.3.7 → fixed in 2.3.7
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper input validation vulnerability in the New customer WebAPI.Successful exploitation could allow an attacker to send unsolicited spam e-mails.
Related
Alias · CVE (1)
- CVE-2021-28585 Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper input validation… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness