GitHub Advisoryadvisory · PyPI

GHSA-c392-whpc-vfpr Apache Airflow vulnerable to Improper Encoding or Escaping of Output

HIGH Published 2024-09-07 Modified 2026-06-05 Official page ↗
Aliases
CVE-2024-45498
Ecosystem
PyPI
Packages
apache-airflow
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-116
Reviewed
2024-09-09

Affected packages

• PyPI apache-airflow: >= 2.10.0, < 2.10.1 → fixed in 2.10.1

Description

Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated attacker with only DAG trigger permission to execute arbitrary commands. If you used that example as the base of your DAGs - please review if you have not copied the dangerous example; see https://github.com/apache/airflow/pull/41873  for more information. We recommend against exposing the example DAGs in your deployment. If you must expose the example DAGs, upgrade Airflow to version 2.10.1 or later.

Related

Alias · CVE (1)

  • CVE-2024-45498 Example DAG: example_inlet_event_extra.py shipped with Apache Airflow version 2.10.0 has a vulnerability that allows an authenticated… vulnerability

Weakness · CWE (1)

  • CWE-116 Improper Encoding or Escaping of Output weakness

References