GitHub Advisoryadvisory · Packagist

GHSA-c3pr-h96w-2jjg Moodle XML import of ddwtos could lead to intentional remote code execution

HIGH Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2018-14630
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: >= 3.5.0, < 3.5.2 → fixed in 3.5.2 • Packagist moodle/moodle: >= 3.4.0, < 3.4.5 → fixed in 3.4.5 • Packagist moodle/moodle: >= 3.2.0, < 3.3.8 → fixed in 3.3.8 • Packagist moodle/moodle: < 3.1.14 → fixed in 3.1.14

Description

moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.

Related

Alias · CVE (1)

  • CVE-2018-14630 moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References