GitHub Advisoryadvisory · PyPI
GHSA-c3rp-4cjh-cp38 Zope does not properly verify the access for objects with proxy roles
HIGH
Official page ↗
- Aliases
- CVE-2002-0170
- Ecosystem
- PyPI
- Packages
- zope
- Severity
- High
- Weaknesses
- CWE-284
- Reviewed
- 2024-02-12
Affected packages
• PyPI zope: >= 2.2.0, < 2.4.4 → fixed in 2.4.4
• PyPI zope: >= 2.5.0, < 2.5.1 → fixed in 2.5.1
Description
Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents in violation of the intended configuration.
Related
Alias · CVE (1)
- CVE-2002-0170 Zope 2.2.0 through 2.5.1 does not properly verify the access for objects with proxy roles, which could allow some users to access documents… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2002-0170 advisory
- https://github.com/zopefoundation/Zope package
- https://launchpad.net/zope2/+milestone/2.4.4 web
- https://launchpad.net/zope2/+milestone/2.5.1 web
- https://web.archive.org/web/20021120034302/http://online.securityfocus.com/bid/4229 web
- https://web.archive.org/web/20070914020022/http://xforce.iss.net/xforce/xfdb/8334 web
- http://marc.info/?l=bugtraq&m=101503023511996&w=2 web
- http://www.redhat.com/support/errata/RHSA-2002-060.html web