GitHub Advisoryadvisory · Packagist
GHSA-c42h-56wx-h85q laravel-auth0 SDK Deserialization of Untrusted Data vulnerability
CRITICAL
Official page ↗
- Ecosystem
- Packagist
- Packages
- auth0/login
- Severity
- Critical
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:H
- Weaknesses
- CWE-1395, CWE-502
- Reviewed
- 2025-06-06
Affected packages
• Packagist auth0/login: >= 7.0.0-BETA1, < 7.2.2 → fixed in 7.2.2
Description
Overview
The laravel-auth0 SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data.
Am I Affected?
You are affected by this vulnerability if you meet the following preconditions:
1. Applications using laravel-auth0 SDK, versions between 7.0.0-BETA1 to 7.2.1.
2. Laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0.
Fix
Upgrade Auth0/laravel-auth0 to the latest version (v7.17.0).
Acknowledgement
Okta would like to thank Andreas Forsblom for discovering this vulnerability.
Related
References
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-v9m8-9xxp-q492 web
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-c42h-56wx-h85q web
- https://github.com/auth0/symfony/security/advisories/GHSA-98j6-67v3-mw34 web
- https://github.com/auth0/wordpress/security/advisories/GHSA-862m-5253-832r web
- https://nvd.nist.gov/vuln/detail/CVE-2025-48951 advisory
- https://github.com/auth0/laravel-auth0 package