GitHub Advisoryadvisory · Packagist

GHSA-c45w-p293-7cv6 Magento 2 Community Edition XSS Vulnerability

MEDIUM Published 2022-05-24 Modified 2024-02-12 Official page ↗
Aliases
CVE-2019-7945
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-14

Affected packages

• Packagist magento/community-edition: >= 2.1.0, < 2.1.18 → fixed in 2.1.18 • Packagist magento/community-edition: >= 2.2.0, < 2.2.9 → fixed in 2.2.9 • Packagist magento/community-edition: >= 2.3.0, < 2.3.2 → fixed in 2.3.2

Description

A stored cross-cite scripting vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. An authenticated user with privileges to modify currency symbols can inject malicious javascript.

Related

Alias · CVE (1)

  • CVE-2019-7945 A stored cross-cite scripting vulnerability exists in Magento Open Source prior to 1.9.4.2, and Magento Commerce prior to 1.14.4.2, Magento… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References