GitHub Advisoryadvisory · Packagist

GHSA-c4c3-j73v-634r silverstripe/framework has Cross-site Scripting vulnerability in page history comparison

MEDIUM Published 2024-05-27 Modified 2024-05-27 Official page ↗
Ecosystem
Packagist
Packages
silverstripe/framework
Severity
Moderate
Reviewed
2024-05-27

Affected packages

• Packagist silverstripe/framework: >= 3.4.0-rc1, < 3.4.6 → fixed in 3.4.6 • Packagist silverstripe/framework: >= 3.5.0-rc1, < 3.5.4 → fixed in 3.5.4

Description

Authenticated user with page edit permission can craft HTML, which when rendered in a page history comparison can execute client scripts.

References