GitHub Advisoryadvisory · RubyGems
GHSA-c4mc-49hq-q275 Puppet uses predictable filenames, allowing arbitrary file overwrite
MEDIUM
Official page ↗
- Aliases
- CVE-2012-1906
- Ecosystem
- RubyGems
- Packages
- puppet
- Severity
- Moderate
- Weaknesses
- CWE-377
- Reviewed
- 2023-08-29
Affected packages
• RubyGems puppet: >= 2.6, < 2.6.15 → fixed in 2.6.15
• RubyGems puppet: >= 2.7, < 2.7.13 → fixed in 2.7.13
Description
Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses predictable file names when installing Mac OS X packages from a remote source, which allows local users to overwrite arbitrary files or install arbitrary packages via a symlink attack on a temporary file in /tmp.
Related
Weakness · not in database (1)
Alias · CVE (1)
- CVE-2012-1906 Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 uses… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2012-1906 advisory
- https://github.com/puppetlabs/puppet/commit/f7829ec1f1b2c3def8e0eda09c22c3c1fed3a27f web
- https://exchange.xforce.ibmcloud.com/vulnerabilities/74793 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-1906.yml web
- https://ubuntu.com/usn/usn-1419-1 web
- https://web.archive.org/web/20120415105345/http://www.securityfocus.com/bid/52975 web
- https://www.debian.org/security/2012/dsa-2451 web
- http://projects.puppetlabs.com/issues/13260 web
- http://puppetlabs.com/security/cve/cve-2012-1906 web