GitHub Advisoryadvisory · Maven
GHSA-c4r9-r8fh-9vj2 snakeYAML before 1.31 vulnerable to Denial of Service due to Out-of-bounds Write
MEDIUM
Official page ↗
- Aliases
- CVE-2022-38749
- Ecosystem
- Maven
- Packages
- org.yaml:snakeyaml, be.cylab:snakeyaml, com.alipay.sofa.acts:acts-common-util, io.prometheus.jmx:jmx_prometheus_httpserver, io.prometheus.jmx:jmx_prometheus_httpserver_java6, org.testifyproject.external:external-snakeyaml, pl.droidsonroids.yaml:snakeyaml
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-121, CWE-787
- Reviewed
- 2022-09-15
Affected packages
• Maven org.yaml:snakeyaml: < 1.31 → fixed in 1.31
• Maven be.cylab:snakeyaml: 1.25.1 (no fix yet)
• Maven com.alipay.sofa.acts:acts-common-util: 1.0.0 (no fix yet)
• Maven io.prometheus.jmx:jmx_prometheus_httpserver: 0.17.0 (no fix yet)
• Maven io.prometheus.jmx:jmx_prometheus_httpserver_java6: <= 0.18.0 (no fix yet)
• Maven org.testifyproject.external:external-snakeyaml: <= 1.0.6 (no fix yet)
• Maven pl.droidsonroids.yaml:snakeyaml: <= 1.18.2 (no fix yet)
Description
Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). If the parser is running on user supplied input, an attacker may supply content that causes the parser to crash by stackoverflow.
Related
Alias · CVE (1)
- CVE-2022-38749 Using snakeYAML to parse untrusted YAML files may be vulnerable to Denial of Service attacks (DOS). vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38749 advisory
- https://arxiv.org/pdf/2306.05534.pdf web
- https://bitbucket.org/snakeyaml/snakeyaml package
- https://bitbucket.org/snakeyaml/snakeyaml/issues/525/got-stackoverflowerror-for-many-open web
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=47024 web
- https://lists.debian.org/debian-lts-announce/2022/10/msg00001.html web
- https://security.gentoo.org/glsa/202305-28 web
- https://security.netapp.com/advisory/ntap-20240315-0010 web